Author Topic: Lost Some of my Style  (Read 3293 times)

Offline wahoo

  • BeerSmith Brewer
  • ***
  • Posts: 28
Lost Some of my Style
« on: October 05, 2011, 05:29:19 AM »
There is definitely a bug which is causing partial loss of data on my system.  If you remember, a week or two ago, I lost my recipes and had to retrieve them from Recipes5.bsmx.

I noticed the other day that I had some styles missing.  I thought perhaps that this was a result of my original data corruption, so I opened an old copy of StylesX.bsmx and copied in all of the styles to my active Styles profile.

I realized at that point that beersmith created duplicates of many of the styles, which does make sense.  I deleted a few duplicates and then made a note to myself to go back and clean this up at a later point in time.

I logged in this morning and noticed that my Styles are gone once again.

I think the fact that I use this on 2 machines on a shared folder must be causing some type of corruption in the DB.   I used this same model with Beersmith 1.4 and never had any problems.


Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5410
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Re: Lost Some of my Style
« Reply #1 on: October 05, 2011, 10:12:47 AM »
Hi,
  Yes - the problem is almost certainly that you are running on two machines.  BeerSmith does not have any data protection (neither did BeerSmith 1.4) so it is possible if you have two copies running for one to overwrite the other - since they periodically autosave.

  I recommend if you use a shared drive, that you be very careful to leave only one copy running at a time or they could potentially overwrite each other and cause corruption of the files.

Brad
Get a free trial of BeerSmith 3 here

Offline wahoo

  • BeerSmith Brewer
  • ***
  • Posts: 28
Re: Lost Some of my Style
« Reply #2 on: October 05, 2011, 08:45:19 PM »
I've never run them both simultaneously.  I also have never edited a style, which leads me to think this is some sort of data corruption issue. 

Offline BeerSmith

  • Brewer, Author, Patriot
  • BeerSmith Administrator
  • BeerSmith Grandmaster Brewer
  • *****
  • Posts: 5410
  • BeerSmith - take the guesswork out of brewing!
    • BeerSmith
Re: Lost Some of my Style
« Reply #3 on: October 06, 2011, 07:39:28 PM »
Hi,
  The other possibility is a bad options setting - check the Options Dialog->Brewing Tab and see which "Display Style Guide" is set - if you don't have a valid entry here such as BJCP 2008 it will not display the styles correctly.

Brad
Get a free trial of BeerSmith 3 here

 

modification